Books
- Lilley, C. Color on the Web. Chapter 16 in Green, P. (editor) (2024) Fundamentals and Applications of Colour Engineering. Wiley. ISBN 978-1119827184
- Watt, Andrew H.; Lilley, Chris, et. al. (2003) SVG Unleashed. Sams. ISBN 0-672-32429-6
- Lin, F.; Wyrwas, K.; Irwin J.; Lilley, C.; Hewitt, W.T.; Howard, T.L.J. (1995) Geometry for Computer Graphics. Sheffield, UCoSDA. ISBN 1-85889-059-4
- Lilley, C.; Lin, F.; Hewitt, W.T.; Howard, T.L.J. (1993) Visualisation 1: Graphical Communication. Sheffield, UCoSDA. ISBN 1-85889-027-6
- Lilley, C.; Lin, F.; Hewitt, W.T.; Howard, T.L.J. (1993) Colour in Computer Graphics. Sheffield, UCoSDA. ISBN 1-85889-022-5
- Lilley, C.; Lin, F.; Hewitt, W.T.; Howard, T.L.J. (1993) Standards for Computer Graphics. Sheffield, UCoSDA. ISBN 1-85889-017-9
Papers & articles
- Lilley, C. Towards an HDR-capable ICC PCS. Expert contribution to the International Color Consortium (ICC), June 2020. HTML.
- Lilley, C. Ask an expert: Why is CSS . . . the way it is?. In Increment magazine Issue 13, May 2020. HTML.
- Lilley, C.; Correll, S. (2003) Extending SVG Fonts with Graphite. In Proceedings of the 23rd International Unicode Conference PDF.
- Lilley, C. (2001) SVG: Unicode meets Vector Graphics. In Proceedings of the 18th International Unicode Conference.
- Lilley, C. (2000) Scalable Vector Graphics. In Proceedings of the Ninth International World Wide Web Conference PDF.
- Lilley, C. (2000) Internationalisation and Localisation with SVG in Proceedings of the 16th International Unicode Conference.
- Lilley, C. (1998) Rendering Multilingual Documents – CSS and XSL in Proceedings of the 13th International Unicode Conference. PDF.
- Nielsen, Henrik Frystyk; Gettys, Jim; Baird-Smith, Anselm; Prud'hommeaux, Eric; Lie, Håkon Wium; Lilley, Chris (1997) Network Performance Effects of HTTP/1.1, CSS1, and PNG in ACM SIGCOMM Computer Communication Review 27(4), pp.155-166 ·October 1997 HTML PDF.
- Lilley, C. (1997) The Design of an International Web Font Extension for Cacading Style Sheets in Proceedings of the 11th International Unicode Conference. PDF.
- Lilley, C (1995) Not Just Decoration : Quality Graphics for the Web. in World Wide Web Journal 1(1), pp.291–307, Boston, 1995. HTML.
- Lilley, C. (1995) Active Web Pages. In Proceedings of the 1995 Eurographics UK Conference, Loughborough, 1995, pp 267–281
- K.W. Brodlie, J.R. Gallop, A.J. Grant, J. Haswell, W.T. Hewitt, S. Larkin, C.C. Lilley, H. Morphet, A. Townend, J. Wood, H. Wright (1995) Review of Visualization Systems. Advisory Group on Computer Graphics Technical Report No. 9. February 1995. PDF
- Lilley, C; Lin, F; Hewitt, W.T.; Howard, T.L.J. (1994) The Design and Development of Distance Learning Materials for Graphics and Visualisation. In Eurographics Workshop on Graphics and Visualisation Education (GVE), Barcelona, 1993. Also reprinted in Computers & Graphics 18(3), pp.269–275. PDF
- Lilley, C. (1994) An Introduction to Standardised Colour Measurement. in Proceedings of the 12th Eurographics UK Conference, 22–24 March 1994 pp.163–177. ISBN 0952109719
Web Standards and other specifications
Date ranges are First Public Draft to Most Recent Publication.
- Atkins, Tab; Lilley, Chris; Verou, Lea (editors) (2026) CSS Color Module Level 4. W3C Candidate Recommendation, 5 July 2016 ‒ 30 September 2026.
- Lilley, Chris (editor) (2021) CSS Fonts Module Level 5. W3C Working Draft, 29 June 2021 ‒ 13 September 2026
- Lilley, Chris; Kravets, Una; Verou, Lea (editors) (2026) CSS Color Module Level 5. W3C Working Draft, 3 March 2020 ‒ 13 September 2026
- Lilley, Chris (editors) (2026) CSS Fonts Module Level 4. W3C Working Draft, 11 July 2017 ‒ 13 September 2026
- Lilley, Chris; Rieger, Garret; Iterum, Skef (editors) (2025) Incremental Font Transfer. W3C Candidate Recommendation. 7 September 2021 ‒ 18 November 2025
- Baron, L. David; Etemad, Elika; Lilley, Chris (editors) (2025) CSS Conditional Rules Module Level 4. W3C Candidate Recommendation. 3 March 2020 ‒ 4 September 2025
- Blume, Chris et. al. (editors) (2025) Portable Network Graphics (PNG) Specification (Third Edition). W3C Recommendation, 25 October 2022 ‒ 24 June 2025
- Lilley, Chris (editor) (2020) Progressive Font Enrichment: Evaluation Report. W3C Working Group Note, 15 October 2020
- Everson, Michael; Lilley, Chris (2019) Proposal for the addition of four Latin characters to the UCS. ISO/IEC JTC1/SC2/WG2 N5044, 26 May 2019. Proposal was later accepted into Unicode.
- Daggett, John; Maxfield, Myles; Lilley, Chris (editors) (2018) CSS Fonts Module Level 3. W3C Recommendation, 21 July 1997 ‒ 20 September 2018.
- Lilley, Chris (editor) (2017) RFC 8081: The font Top Level Type. IETF Proposed Standard, February 2017. ISSN: 2070-1721
- Lilley, Chris (editor) (2015) WOFF 2.0 Evaluation Report. W3C specification, 14 April 2015.
- Thompson, H.; Lilley, C. RFC 7303: XML Media Types. IETF Proposed Standard. 07 July 2014. ISSN: 2070-1721
- Everson, Michael; Jacquerye, Denis; Lilley, Chris (2012) Proposal for the addition of ten Latin characters to the UCS. ISO/IEC JTC1/SC2/WG2 N4297. 26 July 2012.
- Dahlström, Eric et. al. (2011) Scalable Vector Graphics (SVG) 1.1 (Second Edition). W3C Recommendation. 30 October 2001 ‒ 16 August 2011.
- Çelik, Tantek; Lilley, Chris; Baron, L. David (editors) (2011) CSS Color Module Level 3. W3C Recommendation, 23 June 1999 ‒ 7 June 2011.
- Lilley, Chris; Grasso, Anthony (2009) SVG Color 1.2, Part 2: Language. W3C specification, 01 October 2009.
- Anderson, A.; Berjon, R. et. al. (2006) Scalable Vector Graphics (SVG) Tiny 1.2 Specification. W3C Recommendation, 09 December 2003 ‒ 22 December 2008.
- Jacobs, Ian; Walsh, Norm (eds)(2004) Architecture of the World Wide Web, Volume One. W3C Recommendation, 30 August 2002 ‒ 15 December 2004.
- Lilley, Chris (2004) How should the problem of identifying ID semantics in XML languages be addressed in the absence of a DTD?. TAG finding, 30 November 2004.
- Duce, David (editor) (2003) Portable Network Graphics (PNG) Specification (Second Edition). W3C Recommendation. 26 November 1995 ‒ 10 November 2003. Also published as Information technology — Computer graphics and image processing — Portable Network Graphics (PNG): Functional specification. ISO/IEC 15948:2004 (E).
- Lilley, Chris (2003) Separation of semantic and presentational markup, to the extent possible, is architecturally sound. Draft TAG finding, 30 June 2003.
- Diaz, A. et al. (2001) Component Extension (CX) API requirements Version 1.0. W3C specification, 11 December 2001.
- Ferraiolo, Jon (editor) (2001) Scalable Vector Graphics (SVG) 1.0 Specification. W3C Recommendation. 11 February 1999 ‒ 4 September 2001.
- Lie, Håkon Wium; Bos, Bert; Lilley, Chris (editors) (1998) RFC 2318: The text/css Media Type. IETF Informational. March 1998.
- Bos, Bert; Lie, Håkon Wium; Lilley, Chris; Jacobs, Ian (1998) Cascading Style Sheets, level 2. W3C Recommendation, 12 May 1998.
- Lilley, Chris (editor) (1997) Aural Cascading Style Sheets (ACSS). W3C Note, 7 January 1997.
- Lilley, Chris (editor) (1997) Web Fonts. W3C specification, 21 July 1997. This work was later merged into CSS2.
- Lilley, Chris; Platon, Roy (1997) Use of CGM as a Scalable Graphics Format. W3C specification, 18 June 1997.
orcid.org/0000-0001-6379-4176